fix(opensuse): use appropriate upstream repo

master
Imran Iqbal 2 years ago
parent 7fc32fb0fb
commit 5d9a92bf1d
No known key found for this signature in database
GPG Key ID: 6D8629439D2B7819
  1. 7
      salt/osfamilymap.yaml
  2. 5
      test/integration/v201902-py3/controls/pkgs_spec.rb
  3. 7
      test/integration/v3000-py3/controls/pkgs_spec.rb

@ -4,7 +4,7 @@
{%- set py_ver_repr = salt['pillar.get']('salt:py_ver', '') %}
{%- set osrelease = salt['grains.get']('osrelease') %}
{%- set osrelease = salt['grains.get']('osrelease', '') %}
{%- set salt_release = salt['pillar.get']('salt:release', 'latest') %}
{%- if salt_release.split('.')|length >= 3 %}
{%- set salt_release = 'archive/' ~ salt_release %}
@ -12,6 +12,7 @@
{%- set osfamily_lower = salt['grains.get']('os_family')|lower %}
{%- set osmajorrelease = salt['grains.get']('osmajorrelease', osrelease)|string %}
{%- set oscodename = salt['grains.get']('oscodename') %}
{%- set suse_testing_repo = ':/products:/next:/testing' if [osfamily_lower, osrelease] == ['suse', '15.2'] else '' %}
#from template-formula
{%- if grains.os == 'MacOS' %}
@ -54,8 +55,8 @@ RedHat:
Suse:
pkgrepo_humanname: 'Salt releases for SLE-based SUSE products (openSUSE_Leap_{{ osrelease }})'
pkgrepo: 'http://repo.saltstack.com/opensuse/openSUSE_Leap_{{ osrelease }}/'
key_url: 'http://repo.saltstack.com/opensuse/openSUSE_Leap_{{ osrelease }}/repodata/repomd.xml.key'
pkgrepo: 'https://download.opensuse.org/repositories/systemsmanagement:/saltstack{{ suse_testing_repo }}/openSUSE_Leap_{{ osrelease }}/'
key_url: 'https://download.opensuse.org/repositories/systemsmanagement:/saltstack{{ suse_testing_repo }}/openSUSE_Leap_{{ osrelease }}/repodata/repomd.xml.key'
pygit2: python-pygit2
pyinotify: python-pyinotify
gitfs:

@ -18,10 +18,7 @@ version =
end
when 'fedora'
# Issue in the upstream repo, should be `3000.3`
'3000.2-1.fc31'
when 'suse'
# Issue in the upstream repo, should be `2019.2.5`
'2019.2.0-lp151.37.1'
'3000.3-1.fc31'
end
control 'salt packages' do

@ -21,7 +21,12 @@ version =
'3000.2-1.fc31'
when 'suse'
# Issue in the upstream repo, should be `3000.3`
'2019.2.0-lp151.37.1'
case platform[:release]
when /^15.2/
'3000.2-lp152.7.1'
when /^15.1/
'3000.2-lp151.2.1'
end
end
control 'salt packages' do

Loading…
Cancel
Save